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Introduction 
The purpose of this document is to provide a general introduction to the process for 
Creating Label Records in eSIS. The Create Label Records function in eSIS allows the user 
to easily export data from within eSIS to a file which can be used to produce various types 
of labels to meet specific needs. Use of the demographic extract allows the user to select 
specific students to be included on the labels. To complete this process, access to Microsoft 
Excel® and Microsoft Word® is needed. 

 

Note:   The instructions in this document are based on Microsoft Word® 2002, Microsoft 
Excel® 2002, and on the WindowsXP® operating system. While the screen shots may differ 
between the version contained in this document and the versions used by the eSIS user, the 
general functionality and process is the same. 
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Creating Labels Using the Export Function 
There are five basic steps to creating labels in eSIS: 

1. Create a directory to receive exported data . 

2. Select students using the demographic extract. 

3. Create export. 

4. Import data into Excel. 

5. Mail Merge into Word to create the labels of choice. 

 

These steps are described in detail in the following sections. 

 

Step 1: Create a Directory 

The first step is to create a directory on the hard drive to which you can export the labels. 
This step only has to be completed once. 

1. Right click the workstation desktop. 

2. Select New Folder from the menu. 

3. Name the new folder Labels (or use a more specific name such as File Folder 
Labels). A folder named Labels is created on the desktop. 

 

Step 2: Create a Demographic Extract 
The second step is to create a demographic extract to select the students to be included in 
the label. 

 

To access the Demographic Extract screen: 

1. Click the Reports icon on the eSIS Main Start screen. The Student Information 
System Reports screen opens. 

 

 

 

2. Click the Specify Extract Criteria button. 
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Student Information System Reports screen 

 

 

The Demographic Extract screen opens as shown below. 
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Demographic Extract screen 

 

 

Using the Demographic Extract Screen 
In the Demographic Extract screen, you can identify the criteria to determine which 
students will be included in the export file. The tabs across the top of the screen each 
represent a new screen with different fields of information that can be selected to set the 
criteria for the search. 

 

Basic Tab 
When the Demographic Extract screen opens, the Basic tab is selected. 
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Demographic Extract screen 

 

 

The Curr (Current) Year radio button and the Include Cross Enrolled Students 
checkbox are default settings. Below the basic data fields are 3 buttons: 

• Clear Extract Criteria 

• Saved Extracts List 

• Run Extract 

 

To continue creating the extract: 

1. Click the Clear Extract Criteria button to clear all previous choices. 

2. Click the drop-down list above the Include Cross Enrolled Students checkbox to view 
the school(s) to which the user has security access. Click the school name to select 
it. 

3. Click the Include Cross Enrolled Students checkbox to deselect if those students are 
not to be included in the extract. In this example, the checkbox will remain selected 
so that cross-enrolled students will be included in the extract. 

4. Other criteria can be set to further define the group of students to receive the letter. 
For this example, only 10th grade students should receive this letter. 

a. Select “GR 10” in the Grade drop-down list. 

b. Click the Run Extract button. All 10th grade students enrolled at this school 
including 10th grade cross-enrolled students will be included in the extract. 
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The Processing Extract Criteria screen displays as shown below. The 
upper section of the window includes the criteria set for the extract. After the 
extract has been completed, the number of records that meet the criteria is 
displayed. 

 

Processing Extract Criteria screen 
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c. Click See Extract to go to the Results tab to view the information for 
students who met the criteria. The Results tab contains basic information 
about the students: Pupil No., Legal Last Name, First Name, Phone No., 
Home School, HR1, and HR2. 

Note:  Clicking the Go Back button will take you back to the Basic tab. 

 

Demographic Extract screen – Results tab 

 
 

d. Click Exit to return to the Student Information System Reports screen. 

 

Step 3: Create Label Parameters 
To create the label parameters: 

1. In the Student Information System Reports screen, expand the Mailing and 
Correspondence report group. 

2. Double click the Create Label Records Export report. 

 

Student Information Systems Reports screen 

The Run Report: Create Label Records Export screen displays. 
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Run Report: Create Label Records Export screen 

 

 

Note:  The data from the previously run extract is now displayed on the Run 
Report: Create Label Records Export screen. 

 

3. Click the Run Report button. The Create Label Records Export parameter form 
displays, allowing the user to make selections. 

 

Create Label Records Export parameter form 
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4. Four options for labels are available on the Create Label Records Export 
parameter form. Select the option that you prefer for your label export. 

• Students – Generates one record for each student in the demographic 
extract using the student’s mailing address. 

• Living with Student Only – Generates one record for each student 
included in the demographic extract. The export uses the parent/guardian 
mailing address on the Parent Information screen if the Living With 
checkbox is selected. 

• Copy of Correspondence Only – Generates one record for each 
parent/guardian with the Copy of Correspondence checkbox selected on the 
Parent Information screen. 

• Living with Student, Copy of Correspondence – Generates records 
combining the Living with Student Only and Copy of Correspondence 
Only options. 

5. Other fields on the parameter are Semester, Print, and Filename. Set any of these 
options that you prefer for your label export: 
• Semester – Allows the user to select the semester for which the label records 

are to be generated. For example, if homeroom information is selected as 
part of the demographic extract for students and if Semester 1 were selected 
here, then the label records export would only include those homeroom 
assignments for the first semester. 

• Print – The All Capitals checkbox allows the user to indicate if the data to 
be exported should be capitalized. The Family Courier checkbox allows the 
user to indicate if the data to be exported should be based on the Family 
Courier field in eSIS. If the school uses the Family Courier function, only 
one record per family will be produced. 

• Filename will be populated with the name the user gives to the export file as 
well as the path to the directory in which the file is saved. This will be 
addressed in the next step. 

Note:  If multiple parent information records exist and there are differences in the 
parent/guardian mailing address or home phone numbers, multiple records 
will be created for this student (listing both addresses, phone numbers, etc). 
If a student does not have any parent/guardian information entered, a record 
using that student’s mailing address will be created. 

6. Click the Save As button beside the Filename field. This opens the Save As screen. 
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Save As screen 

 

7. In the Save in field, navigate to the location where the original Labels folder was 
created. For this example, the path would be 
C:\Documents and Settings\bsanders\Desktop\Labels\ 

8. In the File name field, specify a name for the labels file. For example, 
“Grade10Labels.xls”. You must add the file extension of .xls to the end of the file 
name for the export to work properly. 

9. Click the Save button to return to the Create Label Records Export parameter 
form. The path and filename that you specified are displayed in the Filename field. 
For example: 

 

 

10. From the Create Label Records Export parameter form, click the Print button. 
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11. A warning message appears to warn you that data is being exported outside of eSIS 
and the eSIS security no longer protects access to this data. Click OK to continue. 
The File Progress window displays as the system is exporting the file. 

 

 

 

12. When the Finished…Writing File message displays, click the  button. 

 

 

13. Exit from the Reports screen. 

Step 4: Import the Label Data into Excel 
To import the label data into Excel: 

1. Open the Excel program by: 

• Clicking the Microsoft Excel® icon on the user desktop, or 
• Navigating to the program from the workstation desktop as follows: 

Navigation: Start > Programs > Microsoft Excel 

CAUTION: DO NOT open Excel by opening the label file created from eSIS or the 
following steps will not work. 

 

2. From the Menu Bar, select File > Open. The Open screen appears. 
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3. In the Look In field, select the path to where the label file was saved. 

Note:  Make sure that the Files of Type field is set to All Microsoft Excel 
Files. 

 

4. Click the filename to select it, then click the Open button. This begins the Text 
Import Wizard process. 
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5. In Step 1 of the Wizard, select the Delimited radio button and click the Next button. 
Leave all other fields at the default settings. 
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6. In Step 2 of the Wizard, change the Delimiter field from Tab to Other: 

a. Click the Tab checkbox to deselect it. 

b. Check Other. In the field beside Other, insert a Tilde (~). The tilde key is 
located to the left of the 1 key on your keyboard. 

7. Click the Next button. The Text Import Wizard – Step 3 of 3 opens. 

 

 

8. Step 3 of the Wizard allows users to perform additional formatting on the data or to 
elect to not import a column. For example, if you wanted to prevent the Pupil 
Number from appearing on the label, you would: 

a. Highlight the column by clicking on the General header button above 
Pupil_Number. 

b. Select the Do not import column (skip) radio button. 

9. Click the Finish button. The data is now imported into Excel. 
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Note:   The columns are often skewed and may require resizing to view the data. Place the 
cursor on a line between two column headings to change it to the crossbow and double 
click. All fields will be adjusted to the correct width. 
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Saving the File 
To save the file: 

1. From the Excel Menu Bar, select File > Save As. The existing filename will have 
quotes around it for example, “10th Grade Labels.xls” and the Save as Type will be 
Text (tab delimited). 

2. In the Save in field, select the location where you want to save the file. 

3. Highlight the existing filename and quotes and type the name you prefer for the file 
in the File name field. 

Note:  If you do not specify a different name for the file, then a message will appear 
asking whether you want to overwrite the existing file. 

4. In the Save as type field, select Microsoft Excel Workbook (*.xls). The xls 
extension will be added to the file. 

 

 

5. Click the Save button. 
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Step 5: Mail Merge the Label File into Microsoft Word® 
To open the Mail Merge window in Microsoft Word®: 

1. From the user desktop, launch Microsoft Word®. 

2. From the Menu Bar, select File > New (Blank Document). 

 

3. Using the Menu Bar, open the Mail Merge window by selecting: 

Navigation: Tools > Letters and Mailings > Mail Merge 

 

Step 1: Setting up the Labels 
1. In the Mail Merge pane that appears, select the Labels radio button. 

 

2. At Step 1, click the Next: Starting Document link at the bottom right hand side of 
the screen to proceed to the next step in the mail merge process. 
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3. Select the Change document layout radio button. 

 

4. Click Label Options to open the Label Options window. 

 

 

5. The radio buttons in the Printer Information area allow the user to select either 
Dot Matrix or Laser and Ink Jet. Tray is used to indicate where the labels will be 
loaded. Select the Label products and Product number that best matches the type 
and measurements of the label to be printed. 

6. Click the OK button. A blank document appears on the screen. This document shows 
formatting changes to accommodate the label type selected by the user. 
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Step 2: Selecting Recipients 
1. In the Step 2 area, click the Next: Select recipients link at the bottom right 

corner of the screen. 

 

2. In the window that appears, select the Use an existing list radio button. 

 

 

3. Click the Browse link. 
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Note:  Be sure to verify that the Files of Type field is set to All Data Sources 
(*.odc; *.mdb; *.mde;, etc.). 

4. In the Look In field, select the correct destination where the label file was saved. 

5. Click the Open button. The Select Table window opens. 

 

 

6. Verify that the correct label file displays, and click the OK button. This opens the Mail 
Merge Recipients screen. 

 

 

7. Click the Select All button. 

8. Click the OK button. 
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Step 3: Arranging the Labels 
To arrange the labels: 

1. Select Step 3 – Next: Arrange your labels at the bottom right hand corner of the 
screen. 

 

 

2. The Arrange your labels pane opens. Select the More Items link in order to set 
the format of the label. 

 

 

3. On the Insert Merge Field window, verify that the Database Fields radio button 
is selected. 
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4. Select the fields one by one in the order in which they should appear on the label: 

a. Select the first field to be included on the label, and click the Insert button. 

b. Click the Close button. 

c. Move the cursor on the label to the position where the second field should 
appear. 

d. Select the More Items link to choose the next field to be included. 

e. Select the field to add and click the Insert button. 

f. Click the Close button. 

g. Repeat this process for all fields needed on the label. 

5. Click the Update All Labels button to add the field names to each label. 
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Step 4: Previewing Labels 
To preview your labels: 

1. Click the Step 4 – Next: Preview your labels link. 

 

2. Labels are displayed on the screen populated with the data fields selected and 
formatted by the user. View your labels to verify that they are formatted correctly. 

 

 

 

 

Step 5: Completing the Merge 
To complete the merge: 

1. Select Step 5 – Next: Complete the merge link at the bottom right corner of the 
screen. 

2. In the Menu Bar, select File > Save As to save the new labels. As mentioned in the 
previous steps, insert the name that you want to appear for the labels (for example, 
“Final 10th Grade Labels.doc”). The file extension will automatically be added if the 
File Save as field is set to Word Document. 

Note:  At this point in the process, it is recommended that before you print the 
entire job, you only print one page of the labels onto plain paper. Hold it up to 
the light with a sheet of the labels lined up behind the printout. Verify all data 
lines up correctly. If it does not, open the label document and reformat either 
the label size or type. 
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Additional Label Examples 
Listed below are some examples of other types of labels that can be created using exported 
data from eSIS. 

 

Mailing labels for all ninth grade students 

 

 

File folder labels with student’s name and address 
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Index Card with sample added text – “Homeroom, Student Phone & Parent Phone” 

 

 

1.63” for round or square labels with student’s name and address. 

 

 

Identification Card format. 

 

 

Fold over Name Tent (Actual size – 1.75” x 7.5”) 
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Creating Specific Labels 
There are specific labels available in eSIS that may be generated based on demographic 
extract information. To generate these labels, the process is the same as discussed 
previously in this document with the exception that data does not have to be exported, and 
there is no need for the use of Microsoft Excel® and/or Microsoft Word®. 

 

To create labels in eSIS: 

1. Click the Reports icon on the eSIS Main Start screen. 

 

 

2. The Student Information System Reports screen appears. Expand the Mailing 
and Correspondence Report Group. 

Student Information System Reports screen 

 

 

3. Double click the canned label to be created (for example, Registration Labels, 
Mailing Labels, Locker Labels, etc). 
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4. Click the Specify Extract Criteria button on the Student Information System 
Reports screen. Follow the instructions included in Step 2 in order to produce a data 
extract containing students needed to appear on the labels. 

5. The Registration Labels parameter form displays, allowing the user to make 
selections. 

Registration Labels parameter form 

 

 

6. Select the appropriate parameters from the drop-down fields. In this example, the 
Home Room Semester chosen is 1 and the Sort method is Alpha. 

7. Click the Print button to preview the labels in Adobe Acrobat Reader®. 
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