Excel-Filters and Pivot Tables
Data from NC WISE is often just a mass of names and information. This document will give you specific
instructions concerning 2 files you may want to analyze. Consider other files and sources—Graduate Data
Verification System from the Reporting Hub, a user specified Discipline extract from Export Ad Hoc File, or copy
and paste Dropout data from the report in Webapps. When you learn to use filters and pivot tables you will find
many uses for them.

Marks Analysis Report-Reporting Hub

There are two possible reports to run. One is called Current Year Marks. It runs by grade level and includes the
course name, but not section numbers. It will be in NC WISE Reports on your Run Reports page. The other is
Current Year Student Grades without Teacher ID. It includes course code and section number, but not Course
Name. You can decide which one will be more useful.

The report should be downloaded as shown below:
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Separator should be Tab, and Column Headers should be checked. It is helpful to keep a “Downloads” folder on
your desktop and put all your extracts in it. | like to use names that indicate both the type of file and the date;
for example, Student Grades 2NW.txt. (All Reporting Hub reports download as .txt files).

Opening the Data in Excel
o Close any other windows that may be open.
e Open Excel (Start>Programs or All Programs>Microsoft Office>Microsoft Excel)
e Click the Office button menu
e Choose Open
e From the Look in drop-down box at the top, choose the location that you saved your data
At the bottom, change the Files of type drop-down to All Files
Either double-click your file name or click your file and then click Open
On the Text Import Wizard screen, choose Delimited and then click Next
Be sure that Tab is checked and click Next
e Click Finish
e If some of your columns contain #######, double-click the divider separating that column and the next
column to resize the column.
e Save the file using Office button /Save as... Click on the up arrow beside Save as file type and choose
Microsoft Office Excel Workbook. (Choose the version you use at school/home.)
Note that ALL reporting periods are included even though there are no grades in some of them. You can filter
and delete those you don’t want, or simply use the pivot table to choose the ones you want to display.

Inserting the Formula for Letter Grades

e Insert a column to the right of the numerical grade. Select the column, right mouse click and choose
Insert. A dialogue box may display. If so, choose Shift cells to right

e Change 12 in the formula to the correct column name for your spreadsheet.

e Copy and paste the formula into cell 2 of the column.
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e Copy it down to all the cells in the column. If you haven’t deleted blank reporting periods, remember
that the formula will return an “NA” for that cell.

=IF(ISBLANK(12),"NA", IF(I2="FF","F" IF(12<70,"F",IF(12<77,"D", IF(12<85,"C", IF(12<93,"B" IF(12<101,"A")))))))

Analyzing the Data

You can add a filter to the first row to look at some very basic information. Click in cell A1, then click Sort &
Filter on the right hand side of the Home menus. Click on Filter.
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You can now filter for a particular Reporting Period or Course Grade.

e Click the arrow beside the column on which you want to filter and uncheck Select All.

e  Check what you want to display.

e If you want to display all students with F’s during 2" 9 weeks, you would click the drop-down for
Reporting Period and check 2" 9 weeks, then on the drop-down beside Course Grade and check F.

e You can print these lists as needed.

e Filters will give you individual student names and lists. To analyze by count or percentage, you will need
to insert a pivot table.

Pivot Tables
PivotTable Options — @ Remember that the pivot table is based on what is on the source data
Hme: | FivotTablot [ screen and includes data that you may have filtered.
Loyout o Formet | Totdls hers | Disioy | Preing | ate e Make sure that you have a column header for each of your
Display ), .
columns and that you don’t have any empty rows in your spreadsheet.

show expandjcollapse buttons

e Clickin cell Al and click Insert>Pivot Table>OK.

e |t'sagoodidea to set up your pivot table so you can have
multiple items in the Rows. To do this, right mouse click in the pivot
table area, choose Pivot Table Options, and check Classic as shown to
the left

Show contextual kaolkips

Display field captions and filter drop downs
[“]iclassic PivatTable lavout (enables dragaing of Fields in the grid)

Field List
O SortAtaZ
() Sort in data source order
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How many A’s, B’s, C’s and D’s did each teacher give in each class?

Drag fields between areas below:
X e Pull the items over as indicated to 7 ReportFiter [l Colmn Labeks
=3 | Copy . Mark Period A Letter Grade =
) the right.
g,‘ Farmat Cells... . ,
3 e For any items that you don’t want
b Refresh . . .
= subtotals, right mouse click on the pivot
Sort table over the label, and uncheck
Filter Subtotal.
v || Subtotal “Course Name’ e The example to the left takes the £ Row Labels I values
Expand/Collapse subtotal off the “Course Name” row label. CourseMame ¥ | | Countoflett., ¥
. . Teacher M i
% | Group. e Make sure you filter Mark Period SeEnE
¥ | Ungroup... for ONLY the period you want to see.
Move e Filter the Letter Grade column-
% | Remove "Course Name" uncheck NA (these are courses for which
. o there is no grade entered).
Oil Field Settings... 8 i . ) [] Defer Layout Update
PivotTable Options.. e Try switching Course Name and
Hide Freld Lis Teacher Name to see how it changes the [0S0 Cln o (6l

Pivot Table.

e To see the student names, double click on the number (for example, if there are 4 students in one class
who are making an F, double click on the number 4). A new worksheet will be generated with the
student names on it.

e When you have printed this sheet, delete it to prevent the file from getting too large: right mouse click
on the tab that says Sheet#, and choose Delete. Say yes to the dialogue box and you will be back at your
pivot table.

What percentage of each letter grade did each teacher give in each class?

. . . Value Field Settings _?
Using the pivot table above, click on Count of Course Grade

under Values. Choose Value Field Settings from the drop-
down, then click on the tab that says Show Values As. You’ll
see Normal highlighted in the drop-down. Change that to %
of row.

Source Mame:  Letter Grade

Cuskom Mame; |Cnunt of Letter @rade |

Summarize by | Show values as

Show values as

Pupil Murmber

Murber Formak uls

Insert a Pivot Chart

If you want to display the information in a graph, click Pivot Table Tools and choose Pivot Chart. Make sure
your data is limited to one teacher, course, or grade level so that the chart will be readable. The table and chart
below illustrate a good Pivot Chart.
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A | B | E D E F G

1 |Mark Period Ist6weeks |7
2
3 |Count of Letter Grade Letter Grade |Z|
4 Course Name |-__7|A B C D Grand Total
3 |[ENGLISHS 9.09% 25.45% 21.82% 12.73% 30.91% 100.00%
6 [EMGLISH 9 AP PREP 39.58% 31.25% 14.58% 8.33% 6.25% 100.00%
7 |[ENGLISH 3 HONDRS 38.71% 22.58% 6.45% 16.13% 16.13%  100.00%
8 |Grand Total 26.87% 26.87% 15.67% 11.94% 18.66% 100.00%
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You can click on the chart to print it.

Discipline Extract

e Create an Export Ad Hoc File with the following fields. The first field did not display in the print screen, but
itis Student Number. Use the Extract to eliminate students without incidents.

e Click Goto Extract

oy s it s
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LEF Testing Method

Incident YWeapaon
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LEF Testing Type Interdiew Marrative
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Lepal District Of Residence J Parent Contacted By ¥who
Legal Last Mame Suffix Parent Contacted Haowe
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Re-entry Date

* Begins With ¢ Endswith ¢ Contai...

License Mumber J Reason Far Change J
Wildcard | Cuery |
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[First Name B

Legal ham - [
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Ethnicity

Grade

Action Type

Action Length

Action First Day

Action Last Day

Action Assigned By
Discipline Site

Incident Date

Incident Occurred Time

Incident Reported By
Incident Reason

Export Help

Saved Exports

Start Over Create File

rage &

Criteria

e C(Click the Misc 3 tab.
Enter an Incident Date
Range. It really doesn’t
matter what you enter—
the extract will pull all
students with incidents in
any date range, but will not
include those without
incidents.

e C(lick the Schools tab

e Click your school’s
name on the left side then
click Add>>.

Click Run Extract




Build the file and save it as usual. Use a filename with .txt as the extension to avoid error messages.

Open the file with Excel as you did the Marks Analysis file. Save it in Excel.

Filtering Data for Only a Certain School Year

e To filter data for only this school year, click the drop-down box for the Incident Date column.
e Click the drop-down for Incident Date and click the + sign beside the year. Check each month that you DO

NOT want to include.

Scroll down

Delete.

Click the row number of the first student after the column headings. This should highlight the entire row.

While holding the Shift key down on the keyboard, click the row number of the last student.
This should highlight all the students in the list with no Incident Reason. Right mouse click and choose

e Go back to the Incident Date column, click the drop-down, and choose All.

Now you can use filters or build a pivot table.

Pivot Tables-Discipline

Remember that the pivot table is based on what is visible on the

source data screen. Make sure that you have a column header for Hame: PiuotTablet i
each of your columns and that you don’t have any empty rows in your lEpmicireme FrEeee Juc by [
Displat
spreadsheet. Make sure you have the date range you want to ;DwExpand,m..apsehutm
exam i ne. Show contextual tooltips
e Clickin cell Al and click Insert>Pivot Table>OK. 1D ey oot oo o oo e

e Set up your pivot table so you can have multiple items in the

Draqg fields between areas below:

“ FReport Filter 7 Column Labels
Gender - Action Type -
Ethnicity s

{] Row Labels ¥ values
Grade s Count of Acti... ™

N [] pefer Layout Update

1  Supervised Activities

ISS - In School Suspension
0SS - 10 days or less

0SS - 11-365 days

0SS - 365 days

Expulsion

Corporal Punishment

o NOYUL b WN

[¥liclassic PivatTable isvout (enables dragaing of Fields in the grid)

Rows. To do this, right mouse click in
the pivot table area, choose Pivot Table

Field List
Options, and check Classic Pivot Table Osartatoz
|ay0ut (%) Sort in data source order

How can | find out how many suspensions and other discipline actions | have for
my date range?

e Make sure your source data has the correct date range.

e When you pull Action Type into the Values area, you may find that it says
Sum of Action Type. If this happens, right mouse click over the pivot table where
it says Sum of Action Type, choose Value Field Settings, and click Count.

e Set up your pivot table as indicated on the left.

Codes for Action Types

23 Conference

24 Lunch Detention

25  Student Pays Restitution

26 Time Out

27  Student Written Warning
28  Revoke Driving Privileges
29  Student Oral Warning

LEA Operated Alternative Learning School 30  Administrative Conference with Parent
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9  Off-Site Operated Alternative Learning School 31  Administrative Conference with Student

10 Alternative Learning Program 32  Work Detail

12 Report to Law Enforcement 33  Homebound Instruction

13  Youth Development Center 34  Saturday Academy

14 Day Reporting Center 35 0SS 1-10 Pending Student Hearing

15 Bootcamp 63  Other

17 Court-ordered Probation 91  Sent home early

18 Day Treatment Program 100 Unilateral change in placement (EC only)
19 Residential Treatment Home or Center 101 Hearing held, no change in placement (EC Only)
20 Hospital Treatment Program 102 Hear held, change in placement (EC Only)
21 Detention 105 ISS Partial day

22 Bus Suspension 135 OSS Immunizations

Who is referring students to the office?

e Instead of Grade in the Row Labels, pull in Incident Reported By.
e Notice that Gender and Ethnicity are in the Report Filters. You can find numbers for either of these by
choosing from the drop-downs there. You can also pull ethnicity over to the Row Labels to see if a
teacher is referring a disproportionate number of minorities.

Draag fields between areas below: . . . .
“¢ Report Filter B Column Labels What infractions are causing students to come to the office?

Gender - .

— = e Pullincident reason over to the Row Labels and to the Values. Make
sure the values say “count” not “sum.” If it says sum, right click on the pivot
table over Sum of Incident Reason, and choose Count.

e If you want to see which incident reasons resulted in which actions, pull
Action Type over the Column Labels.
1] RowLzbels E  Values
Incident Reason * Count of Ind... ~

B [] pefer Layout Update

Drag fields between areas below:

Which students have multiple infractions? “F ReportFiter [ Column Labels
53 | Copy Gender w7 Action Type A
R Format Cells... e Set up your pivot table as indicated to the Ethnicity hd
9 Refresh right. You will see a mess on your table.
- R e Right mouse click on the pivot table on
- , | Legal Name. You will see the choices to the left.

- e Uncheck Subtotal Legal Name to remove
Subtotal "Legal Mame

the subtotals and make the table readable. 12] RowLabeks T values
Expand/Callapse ] . . .
f e Repeat this process with any other fields Grade + || | Countof Acti...
Group.. -

that have subtotals. Legal Hame
Ungroup.. First Mame ~
Maove 3

Remove "Legal Mame
Field Settings...
PivotTable Optians...

L 4
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How can | find the number of days suspended or missed from
instruction?

71 m ¥

> 1 Goendar @

, :
insert Delte Fomat | e e You’'ll have to do this on the source data sheet.
= - = o Clear = i ~ - . . .
SRR e Click on cell Al. Click on Data>Filter.

Cells Editing
e Onthe Action Type filter, check the Action Types you want
to count.

e To count the days missed due to ISS, deselect Select All and check 2.

e Scroll down to the very bottom of the column which has Action Length as a header, click in the cell
below the last entry.

e Click AutoSum on the right hand side of the Home ribbon. Verify that the program has chosen the cells

in the column you want to count, and click enter. This will give you the total number of days spent in
ISS.

e You can change your data filter to count OSS, Behavior Lab, etc.
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